Where did the delete button go?

The delete button seems to have disappeared from the side panel. What’s up?

This seems to be happening on some screen sizes and not others. Mostly laptop orientation. It’s on our list to get fixed very soon. @sergio will be getting to it soon! In the meantime, you can cancel an item with a CTRL+Click on the checkbox. Or with a CTRL+SHIFT+ENTER. Or you can delete an item by deleting the text of the item and hitting backspace. Sorry for the inconvenience! Should be fixed soon. Thanks!

Thank you very much James! Deleting the text and pressing backspace works for some items but not others. There seems to be some kind of glitch associated with text in the notes section. I can’t delete an item that has notes, and the notes sometimes reappear after deleting.

Not so much a glitch as we just don’t want to let someone accidentally delete an item that still has text in the notes area. Using the backspace key could make this happen too easily. So we allow the deletion in there is nothing in notes. I hope to get the delete key viewable on all screen sizes soon.

Makes sense, but the issue is that for some reason I can’t delete the notes on certain tasks. When I delete the notes, the little paragraph symbol next to the task remains. If I highlight a different task then click on the first task again, the notes reappear. This just started happening recently. Sometimes I am able to delete tasks with notes by using backspace but the notes would transfer to the task above and couldn’t be deleted.

This has been fixed. Thanks for your patience!

No problem James, thanks for creating such a useful app! Seems to work now. It’s still behaving a little bit funky–I currently have one action which has the little notes indicator next to it despite the fact that there are no notes, both the notes fields (the one that toggles below the action and the one in the sidebar) read “write something here” so I’m sure there’s no text. Also, sometimes it seems like the notes field in the sidebar is not syncing with the one that toggles in the action list–but that was a while ago that I experienced that and you may have fixed it. I was able to delete all the old action items and that’s what I really wanted.

Hmm, that is a little strange. Can you send a screenshot of that to support? Also, how was this item created? Did you send it in as an email? Or was it created directly in GTDNext?

I’m having the same problem. I forward a lot of emails into GTD Next, then go to the task list to clean them up and categorize them. Just now, I’ve tried deleting the text from the Notes section of the task, but cannot. The notes area shows as blank once I hit the Delete key (Mac OS), but if I click away and come back, the text is there.

Solutions tried:
Changing browsers. Problem noticed in Safari, but still there in Chrome.
Changing keys use. Tried both Delete and Fn-Delete. Neither does a permanent delete.

The tasks have the Notes indicator. It doesn’t matter whether I click the indicator and do the deletion inline, or if I do the deletion in the side panel.

Don’t remember having this problem before. Thoughts?

Can you try going into the notes section and hitting CTRL+A (or the Mac equivalent) and then hitting the delete key. That should clear out any notes.

I know this is ridiculously old – but I’m back trying to work a bunch of emails that I’ve forwarded into GTDN, and I’m still having the problem.

I can delete all the content in the note section, and if I move away from the item (on to another one), it is still there. It’s like I need some sort of Save button for edits in the Notes section.

Now, if I delete everything, then type a single character (like a space), it keeps the single character. Then, if I come back and delete the single character, it finally clears out the notes section.

I suppose I could just have single spaces in the notes sections of my tasks … but I thought it might be a bug you’d want to know about. The four-step process to clear them out (delete all, type space, move away, come back and delete space) is a little annoying, but not horribly so.

This seems odd. Have you tried doing a CTRL+A to select all and then hitting delete?

Yes, definitely.

Wondering if it is some difference betweent the Mac OS and Windows OS.