My tasks and projects are not on my screen this morning (4/6/17)

I have logged in to GTDNext this morning on both my laptop and my phone and I have not been able to access my tasks and projects. Everything was normal last night. When I log in on my laptop I have the same screen I had when I first started (ie the tutorial video is on the screen). On my phone the loading gif remains on screen.
I see on the blog that an update was done yesterday (4/5). I’m a little concerned that my life was just erased.


My apologies for the issue. Your data is safe. Yes, we did a large release yesterday and sometimes that get’s people’s browser a bit confused.

Can you please hit refresh a few times on the login page and then hit CTRL-F5 while login in? That should force the old code out and the new code in.
Please let me know if you still see problems and we can do more troubleshooting.


Thanks for your email confirming that these steps worked for you. I will mark this as resolved now.

I seem to be experiencing the same issue, which started yesterday afternoon (April 5). I can access the site fine on my iPhone (Safari) but not on my PC (IE11, Firefox or Chrome). All I get is the “Loading” image, with the video greyed out in the background. I’ve tried the steps you suggested above, to no avail.


I’m having the same issues. Stuck on a “Loading” screen.

@JonCr and @Talyn - Sorry for the troubles.

If hitting CTRL+F5 a few times and refreshing the page isn’t working let’s try the following:

  1. Open up an Incognito or InPrivate browser window and try logging in there. Does that work?
  2. If so, then please delete your cookies and browser history and re-try GTDNext with the CTRL+F5.

Let me know if that helps.

The Incognito setting worked, so I deleted history and it seems to work now. Thanks for the help!

1 Like

Thanks for the quick reply! I tried private browsing in IE and Firefox, but it’s still not working. I forgot to mention in my last post that I had already tried clearing my cache in IE.

@Talyn - That is strange. Sergio is looking into this - Can you try on a different computer or phone/tablet?

It does work on my iPhone with Safari. I get the “Loading…” image, but after a few seconds it disappears and I can access my data.

Okay - Sergio will have to look into it. Apologies for the inconvenience!

I have also tried the Incognito and clearing the cookies on Chrome and IE but am also still receiving the “Loading…” screen.

We’ve made some changes today that hopefully have fixed this issue.

If you are still having this issue and can’t get in at all. Please contact me via the “contact support” button at If you want to provide your username and we will look into your case individually.

Also, please note: Earlier today we released some new code to help with this issue. When we do that, everyone hit’s the server at the same time to go back online. You many see a longer than normal “Loading” sign as everyone get’s back online. We will work at reducing that wait time as well.