GTDNext is misbehaving this morning

I’m having lots of problems. It’s hard to generalize the problems I’m having - it includes sporadic inability to toggle buttons, inability to move items, items dissappearing from a view after being marked with the explanation point, several other things. I have tried reloading the page, restarting my brower, and logging out and back into GTDN.
-Windows 7
-current Chrome
Does this site use Flash? I just this morning updated my Flash. (This may be a stupid question, I have no idea what Flash does).

Just discovered that I am not having this problem when using Firefox.


I use chrome and am not having any issues. Can you try something for me? Can you disable all your Chrome extensions and then try it? I’m wondering if perhaps one of your extensions is interfering with GTDNext.

Ok. I just tried it and it didn’t seem to make a difference. One thing I am noticing now though is that it seems like it is not actually misbehaving in the way that I originally thought. It is just taking so long to complete an action, that it seems like it’s not doing what you want, but if you wait long enough (20-40 seconds) it actually does work.

I guess if you don’t get any other reports of this, it must just be some local problem. If I get a moment later tonight I’ll try it on another computer and see if I can reproduce the problem.

Sorry, I guess that was a false alarm. Although I haven’t resolved the problem, it seems to only happen one of the three computers I’ve checked.

No, problem. I will mark this as as resolved, but it still bothers me that it is happening on one computer. Is it on same internet connect? speed issues? Also only on Chrome on that computer and no extensions? Very strange.

The only thing I can think is that Chrome uses a ton of memory relative to Firefox. The problematic computer probably has a smallish amount of RAM (I’m not sure how much, it’s at home).