I have some serious objections to some of the terms used in the app. To some extent my objections are related to my views on the underlying functionality as such, but I’d say the objections hold under any circumstances (but I’ll comment below, where necessary).
The things I want to bring up here are:
the term Active as in Inbox, Active, Waiting, Scheduled, Someday
the term Next as in Force Next
the term Force as in Force Next
The term “Next” as in Force Next is too narrow, because it will apply to all “types” (Waiting etc, too, not just Next), to control whether or not the tasks will be visible simultaneously on the “current” lists.
The term “Active” as a “type” name for Next actions is highly confusing for several reasons.
1) It does not match the name of the corresponding main/current list (which is called Next actions).
2) It is inconsistent to have two names for just next actions but not for the others (and I certainly would not recommend you to have dual names for all, e.g. to have an “Expecting” type showing up on the Waiting list, and a “Timed” type showing up on Scheduled etc ). Better to have just one name for each.
3) It has a high risk of being misunderstood as the opposite of Inactive, which is the common term for projects etc that are “turned off” (disabled). “Active” sounds as if has something to do with inactivation and/or sequential logic, whereas, compared with Waiting, it is only a matter of whether its is I or someone else who will do the task a.s.a.p., i.e. whether it is intended to be a Next action or a Waiting For action.
4) It indirectly raises anxious questions about the other types (“What? Are my Someday and Waiting turned off somehow? Inactive?”)
The term “Force” in “Force Next” is highly dubious - misleading and causing anxious questions - as a descriptor of its main functionality. Its main function is to simply make tasks visible simultaneously on the “current” lists, i.e. make them parallel, if they weren’t already, and to lay this behavior down in advance for larger projects. This is nothing that needs to be “forced”. It is the “natural” way that people expect. Tasks should be visible on whichever “current” list they were entered for, unless the user decides to “hide” them, and there should be defaults in place to ensure that this works safely. Regardless of how this is done exactly, parallel is something very natural indeed - the most natural, actually - and does not deserve a strong word such as Force, which implies some kind of exception. In fact, it does not even need a name or checkbox at all, since its main function is fully implicit in the task not being marked as Sequential (the “Sequential” checkbox simply not checked. If it is not sequential, then it is parallel; no word or checkbox needed).
However, the term “Force” might be appropriate in an advanced different scenario, almost like an alternative Focus shortcut (a “Prefocus” shortcut ;-)), hotwiring absolutely anything at all even from the deepest and remotest corners of the future outline and onto the “current” lists, regardless of all sequential and similar settings in the outline that may block it. This might perhaps be useful in some cases, who knows? The funny thing is that this advanced function already exists. This is how the Force Next function actually works today - an unfortunate side effect of how it works; unfortunate because it sabotages its main function in sequential subprojects, precluding these from being planned in advance for intended parallel actions. But this nevertheless could be a feature, too - an entirely separate feature - a Forced Prefocus hotwire (could also be called “Forced Visibility” or “Forced Current” etc). In this case the term forced would be OK, because it is an extreme override of the natural/planned flow, quite similar to the Focus override. This extreme feature really has no significant bearing on the regular planned parallel/sequential functionality in general and should not be visualized or managed or named using the green/gray icons or similar terminology. Maybe it could have a pink Focus icon? Maybe two separate checkboxes for Focus and Prefocus (rename Forced Next to Prefocus)? This is not a feature that I request. In fact, I see very limited use for it, and the whole Force Next checkbox could be removed, but if it is kept in some form it should be made totally separate from the sequential/parallel functionality, and named in such a way that no confusion can arise.